User Tools

Site Tools


  Main   About   Help   Download
nconf:help:requirements

NConf system requirements

  • Apache webserver
  • PHP 5.x or higher, php-mysql, php-ldap (only if using LDAP auth)
  • MySQL 5.0.2 or higher (with InnoDB!)
  • Perl 5.6 or higher, perl-DBI, perl-DBD-MySQL
  • Nagios 3.x or Icinga 0.8x (binary required to run syntax checks)

php.ini settings:

  • short_open_tag = On
  • register_globals = Off
  • magic_quotes_gpc = Off

Compatibility:

NConf has been tested on Red Hat, Fedora and CentOS Linux.
It has not been tested on Windows or any UNIX, nor with SELinux.

Security considerations:

NConf is intended to be deployed within a private network or intranet zone. As such, development focus is clearly not that of a secure Internet application. Although it can be run anywhere, we do not advise users to publish NConf in a public DMZ.

nconf/help/requirements.txt ยท Last modified: 18.01.2012 15:40 by agargiulo